Android users may experience issues when opening the eToro application.
Incident Report for eToro
Resolved
The issue is resolved.
Please make sure to update eToro application to the latest version.
Posted 6 days ago. Sep 14, 2018 - 14:29 BST
Investigating
Customers using Android operating system version 5 or lower might experience difficulties opening the eToro application.

In order to resolve this issue, please update your OS version.

If you are unable to update your device’s OS, please note that we will be releasing a fix in our next app update. In the meantime we would suggest using your phone’s internet browser to access the platform.

Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for any inconvenience this may cause
Posted 13 days ago. Sep 07, 2018 - 11:03 BST