Trading is partially unavailable.
Incident Report for eToro
Resolved
the issue has been resolved
Posted Jan 19, 2020 - 07:26 UTC
Investigating
We are currently investigating this issue.
Posted Jan 19, 2020 - 06:56 UTC
This incident affected: Trading (Manual trading - Real, Automatic execution, CopyTrading).