Feed is currently unavailable
Incident Report for eToro
Resolved
Issue has been resolved.
Posted Mar 23, 2020 - 16:05 UTC
Investigating
We are experiencing a temporary issue with our News Feeds. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Mar 23, 2020 - 14:20 UTC
This incident affected: eToro Platform (Feeds).