eToro Platform and Wallet Application Login Issues
Incident Report for eToro
Resolved
The incident has been resolved.
Functionality has been fully restored.
We apologize for the inconvenience.
Posted 29 days ago. Jan 22, 2019 - 12:48 GMT
Monitoring
We experienced temporary technical difficulties that affected login.
All systems are now up.
We will keep monitoring the system to ensure full functionality.
We apologize for the inconvenience.
Posted 29 days ago. Jan 22, 2019 - 09:50 GMT
Update
We are continuing to investigate this issue.
Posted 29 days ago. Jan 22, 2019 - 09:45 GMT
Update
We are continuing to investigate this issue.
Posted 29 days ago. Jan 22, 2019 - 09:44 GMT
Investigating
We are experiencing temporary technical difficulties.
Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 29 days ago. Jan 22, 2019 - 09:43 GMT
This incident affected: Apps (Login) and Wallet.