Login to the platform is alternately unavailable
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Nov 02, 2020 - 15:14 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Customers might experience failures in login
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Nov 02, 2020 - 14:53 UTC
This incident affected: Login & Registration (Login).