PayPal deposits close eToro platform on IOS devices for some customers
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Oct 20, 2021 - 23:01 UTC
Identified
Please note that we currently have technical issues with one of eToro’s services due to 3rd party vendor failures.
We are following the 3rd party vendor status and will provide additional information as soon as possible. We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 20, 2021 - 22:18 UTC
This incident affected: Payments (PayPal).