Watchlist is unavailable
Incident Report for eToro
Resolved
Watchlist is now working properly.
We apologize for the inconvenience.
Posted 5 months ago. Feb 17, 2019 - 10:01 GMT
Identified
Our Watchlist page is currently down. We apologize for the inconvenience and appreciate your patience as we work on resolving the issue.
Posted 5 months ago. Feb 17, 2019 - 09:39 GMT
This incident affected: Apps (Watchlist).