Some clients from US regions may experience issues with Login
Incident Report for eToro
Resolved
This incident has been resolved
Posted Apr 26, 2020 - 17:03 UTC
Monitoring
We are experiencing a temporary issue with our login service. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Apr 26, 2020 - 13:45 UTC
This incident affected: Login & Registration (Login).