eToro platform was partially unavailable

Incident Report for eToro

Resolved

This incident has been resolved.
Posted Jul 17, 2020 - 22:02 UTC

Investigating

Please note that we had technical issues with one of eToro’s services.
The issue on eToro service has been resolved.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 17, 2020 - 21:00 UTC
This incident affected: Website.