An issue for completion of account and deposit
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue for completion of account and deposit has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 26, 2020 - 11:08 BST
Identified
The root cause of the issue has been identified and our developers are working to fix it. During this time customers may experience an issue for completion their accounts and deposit.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 26, 2020 - 10:26 BST
This incident affected: Payments (Deposit).