Login to etoro.com is partially unavailable
Incident Report for eToro
Resolved
Login to etoro.com is available. Issue has been resolved.
We are apologize for the interruption.
Posted Feb 26, 2020 - 22:57 UTC
Investigating
We are apologize for the interruption, and we are working to solve the issue as soon as possible.
Posted Feb 26, 2020 - 21:57 UTC
This incident affected: Login & Registration (Login).