Some customers might not see statistics updating on eToro platform
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 25, 2022 - 10:34 UTC
Identified
The root cause of the issue has been identified and our engineers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 25, 2022 - 09:58 UTC
This incident affected: eToro Platform (Daily Gain).