Trading actions are partially unavailable - Virtual Environment
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The incident has been resolved.
We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jan 28, 2024 - 11:18 UTC
Update
We are experiencing a temporary issue with our Trading actions (Trade, Buy, Sell) in the Virtual Environment
Trading in the main platform is working as expected.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jan 28, 2024 - 10:55 UTC
Update
We are experiencing a temporary issue with our Trading actions (Trade, Buy, Sell) in the Virtual Environment
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jan 28, 2024 - 10:47 UTC
Identified
We are experiencing a temporary issue with our Trading actions (Trade, Buy, Sell).
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jan 28, 2024 - 10:29 UTC
This incident affected: Trading (Manual trading - Virtual).