Login to the wallet app is currently unavailable due to failures on a 3rd party vendor side
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Mar 05, 2021 - 05:36 UTC
Monitoring
We have implemented a solution to resolve the issue and will monitor it for the next few days to make sure it is successfully resolved.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 04, 2021 - 23:36 UTC
Update
We are following the 3rd party vendor status and will provide additional information as soon as possible.

We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 04, 2021 - 22:54 UTC
Update
Some customers may experience login failures due to 3rd party technical issues
Posted Mar 04, 2021 - 21:59 UTC
Update
The ETH requests processing still takes longer than usual, this issue is still under investigation.

We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 04, 2021 - 19:55 UTC
Update
An update: the ETH requests processing takes longer than usual, until this issue will be fully resolved.

We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 04, 2021 - 16:25 UTC
Update
Dear eToro Customers and Partners,
The issue has been resolved for the below coins.
Transactions for these coin types should once again be operable.
XRP
LTC
ALGO
XLM
ZEC
DASH
TRX
BCH
BTC and ETH are still in progress.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Mar 04, 2021 - 15:36 UTC
Identified
We are following the 3rd party vendor status and will provide additional information as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 04, 2021 - 13:17 UTC
Update
We are following the 3rd party vendor status and will provide additional information as soon as possible.

We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 04, 2021 - 12:46 UTC
Investigating
We are following that 3rd party vendor status and will provide additional information as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 04, 2021 - 12:22 UTC
This incident affected: Wallet.