Wallet is currently unavailable
Incident Report for eToro
Resolved
This incident has been resolved.
Posted Apr 30, 2020 - 06:51 BST
Investigating
We're currently having a technical issue with Wallet service.
We're apologizing for the inconvenience.
Posted Apr 30, 2020 - 06:02 BST
This incident affected: Wallet.