Some instruments are not available for trade
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Apr 08, 2021 - 18:18 UTC
Investigating
Please note that we currently have technical issues with one of eToro’s services.
During this time, customers won't be able to trade in the following instruments: NTDOY, HTZGQ, HMMJ and RENN.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Apr 08, 2021 - 17:59 UTC
This incident affected: Trading (Manual trading - Real).