Stats is not loading
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The incident has been resolved.
We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted May 18, 2023 - 08:53 UTC
Investigating
We are experiencing a temporary issue with the daily change.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted May 16, 2023 - 14:52 UTC
This incident affected: eToro Platform (Daily Gain).