Some clients from East Asia regions may experience issues with Login and Trading
Incident Report for eToro
Resolved
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here. Apologise for the interruption.
Posted Apr 22, 2020 - 15:36 UTC
Monitoring
We've found the root cause for the issues and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here.
Posted Apr 22, 2020 - 09:46 UTC
Identified
There is possible issues with deposit as well. We're working on a solution
Posted Apr 22, 2020 - 07:44 UTC
Investigating
We're currently having a Partially login and trading issues in east countries - some of the users may experience failure login and trading issues.
Posted Apr 22, 2020 - 06:59 UTC
This incident affected: Login & Registration (Login), Trading (Manual trading - Real, Automatic execution, CopyTrading), and Payments (Deposit).