Deposits via Credit Card issue
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The deposit via credit card issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 20, 2020 - 18:23 BST
Update
The 3rd party provider has updated that they are still working on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 20, 2020 - 13:55 BST
Identified
Customers may experience an issue when trying to deposit funds via Credit Cards.
The root cause of the issue has been identified as a problem with our 3rd party provider.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 20, 2020 - 06:34 BST
This incident affected: Payments (More).