eToro Money payment method is disabled
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 10, 2022 - 17:32 UTC
Monitoring
We have implemented a solution to resolve the issue, and will monitor it for the next hours to make sure it is successfully resolved.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 10, 2022 - 17:29 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 10, 2022 - 16:28 UTC
Identified
Hello dear customer,

eToro Money payment method is disabled on eToro platform, please pick a different payment method for now.

The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 10, 2022 - 15:36 UTC
This incident affected: Payments (Deposit).