Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2025 - 02:00 UTC
Scheduled
To consistently ensure that you have the latest features and capabilities at your fingertips, eToro performs periodic upgrades to our system.
One of our 3rd party partners will undergo maintenance on August 27, 2025, between 02:00 UTC and 04:00 UTC.
During this window, a downtime of approximately 10 minutes is expected.
For the duration of the downtime, there will be a delay in incoming and outgoing payments for EUR and the GBP account (aka eToro Money) users in Europe and the UK. eToro Card transactions and transfers between the EUR/GBP account and eToro will be declined until after the maintenance has been completed.
We apologize for any inconvenience and appreciate your understanding in this matter.
Posted Aug 21, 2025 - 09:23 UTC
This scheduled maintenance affected: eToro Money (Cash Account, Fast Transfer (Online Banking)).