Some HK stocks are not available for trade
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 12, 2022 - 06:51 UTC
Identified
Due to a technical issue on our 3rd party provider, some customers may experience trading failures in some HK stocks.

We are following the 3rd party provider status and will provide additional information as soon as possible.

We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 11, 2022 - 16:54 UTC
This incident affected: Trading (Manual trading - Real).