Outbound eToro Money Payments Temporarily Halted

Incident Report for eToro

Resolved

The issue affecting outbound payments from eToro Money has now been resolved.

All outbound payments are now fully enabled, and clients can complete their transactions as expected.

We sincerely apologize for the inconvenience and appreciate your patience while our team worked to resolve the issue.

Thank you for your understanding.

Sincerely,
The eToro Team
Posted Aug 07, 2026 - 14:09 UTC

Investigating

Due to an incident, we are temporarily halting all outbound payments from eToro Money in the EU, UK and Australia.

Our team is actively investigating the issue and working to restore full functionality as quickly as possible.

We apologize for any inconvenience this may cause and will continue to keep you updated on our progress here.

Sincerely,
The eToro Team
Posted Aug 07, 2026 - 08:41 UTC
This incident affected: Payments (Withdrawal).