KYC unavailable
Incident Report for eToro
Resolved
All issues were resolved since 09:17 PM (UTC)
We apologize for the inconvenience
Posted Jun 16, 2019 - 22:46 BST
Investigating
Withdraw and Deposit functionalities are unavailable.
We are working to resolve the issue ASAP
Posted Jun 16, 2019 - 21:11 BST
Identified
We are working to resolve the issue as fast as possible.
We are apologizing for the inconvenience.
Posted Jun 16, 2019 - 20:00 BST
Update
We are continuing to investigate the issue.
Posted Jun 16, 2019 - 18:00 BST
Update
We are continuing to investigate the issue.
Posted Jun 16, 2019 - 17:03 BST
Investigating
Our KYC is currently down. We apologize for the inconvenience and appreciate your patience as we work on resolving the issue.
Posted Jun 16, 2019 - 16:06 BST
This incident affected: Payments (Credit Cards, PayPal, Wire Transfer, More, Withdrawals).