Some customers may experience a degradation in service due to problems with our cloud provider
Incident Report for eToro
Resolved
Hello
The incident is resolved and service has been fully restored.
We appreciate your patience and apologize for the inconvenience.
Thank you,
The eToro team
Posted Jul 21, 2022 - 11:11 UTC
Monitoring
Hello
A fix has been applied and we are actively monitoring the system to make sure service is fully restored.
We will update again once the issue is deemed fully resolved.
We thank you for your patience and apologize for the inconvenience.
The eToro team
Posted Jul 21, 2022 - 07:20 UTC
Update
Hello
Our engineering team is still hard at work with our cloud provider on mitigating and resolving the issue.
We will continue updating with progress.
We appreciate your patience and apologize for the inconvenience.
Thank you
The eToro team
Posted Jul 21, 2022 - 06:19 UTC
Investigating
Hello
Due to problems with our cloud provider, some customers may experience a slight degradation in service. Our engineering team is actively monitoring the situation and working together to resolve any issue that may affect the service.
We appreciate your understanding and apologize for any inconvenience.
Thank you
The eToro team
Posted Jul 21, 2022 - 05:42 UTC
This incident affected: Payments (Deposit).