Some Customers might experience problems with deposits from eMoney to the payment method
Incident Report for eToro
Resolved
Dear eToro Money Customers,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 24, 2022 - 13:42 UTC
Investigating
Please note that we currently have technical issues with one of the eToro Money services.
Our team is working hard to resolve this issue.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 24, 2022 - 12:55 UTC
This incident affected: Payments (Deposit).