Etoro subdomains might not be reachable for some customers due to 3rd party provider technical issue
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Nov 04, 2021 - 18:49 UTC
Update
We are following the 3rd party vendor status and will provide additional information as soon as possible. We appreciate your understanding and apologies for the inconvenience.

Sincerely, The eToro Team
Posted Nov 04, 2021 - 16:47 UTC
Investigating
We are following the 3rd party vendor status and will provide additional information as soon as possible. We appreciate your understanding and apologise for the inconvenience.

As a work around solution, please connect directly go www.etoro.com

Sincerely, The eToro Team
Posted Nov 04, 2021 - 14:45 UTC
This incident affected: Website.