Deposits delay and account access issues in mobile
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Sep 17, 2020 - 00:07 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.
Posted Sep 16, 2020 - 23:27 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.
Posted Sep 16, 2020 - 22:15 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.
Posted Sep 16, 2020 - 20:59 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.
Posted Sep 16, 2020 - 19:53 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.
Posted Sep 16, 2020 - 19:09 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 16, 2020 - 18:20 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 16, 2020 - 17:22 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Costumers may experience delay in the deposit window (deposit process will work but with a delay), as well as experience an issue with access their account, both issues in mobile only.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 16, 2020 - 16:44 UTC
Investigating
Please note that we currently have technical issues with deposits via Mobile .
Our team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 16, 2020 - 15:38 UTC
This incident affected: Payments (Deposit) and Platform (Account verification).