Users may not receive recover password and change password confirmation email
Incident Report for eToro
Resolved
All notifications are now working properly.
We apologize for the inconvenience.
Posted 6 months ago. Nov 26, 2018 - 22:45 GMT
Update
We are continuing to investigate this issue.
Posted 6 months ago. Nov 26, 2018 - 22:29 GMT
Investigating
We are experiencing a temporary issue with our notifications service.
Users may not receive recover password and change password confirmation email.
We apologize for the inconvenience.
Posted 6 months ago. Nov 26, 2018 - 22:04 GMT
This incident affected: Apps (Notifications).