Deposits via ACH is unavailable
Incident Report for eToro
Resolved
The issue has been resolved.
Posted Dec 09, 2019 - 08:59 GMT
Investigating
Deposits via ACH is currently unavailable.
Our engineers are investigating the issue.
We apologize for the inconvenience and appreciate your patience as we work on resolving the issue.
Posted Dec 09, 2019 - 07:30 GMT
This incident affected: Payments (More).