Deposits and complete KYC process are working partially
Incident Report for eToro
Resolved
Issue has been resolved. We are sorry for the inconvenience.
Posted Mar 14, 2020 - 10:22 GMT
Update
We are continuing to investigate this issue.
Posted Mar 14, 2020 - 07:09 GMT
Investigating
Some of the users may experience an issue with completing their profile, and deposit.
Apologize for the interruption, we are doing the best to solve this issue ASAP.
Posted Mar 14, 2020 - 07:06 GMT
This incident affected: Payments (More).