Clients from Indonesia may experience an issue with loading Charts
Incident Report for eToro
Resolved
This incident has been resolved
Posted May 08, 2020 - 07:20 UTC
Update
We are continuing to investigate this issue.
Posted May 08, 2020 - 05:49 UTC
Investigating
We are experiencing a temporary issue with our Charts. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted May 08, 2020 - 05:48 UTC
This incident affected: eToro Platform (Charts).