No virtual money in account for new registers in Demo
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jan 03, 2021 - 13:32 UTC
Investigating
Please note that we We are experiencing a temporary issue with virtual equity for new registers in demo account.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 03, 2021 - 12:46 UTC
This incident affected: eToro Platform (Portfolio - Virtual).