Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 25, 2025 - 01:00 UTC
Scheduled
To consistently ensure that you have the latest features and capabilities at your fingertips, eToro performs periodic upgrades to our system.
One of our 3rd party partners will undergo maintenance on September 25, 2025, between 01:00 UTC and 03:00 UTC.
During this window, a downtime of approximately 20 minutes is expected.
Please note that during this window, payments between trading accounts and EUR/GBP (eToro Money) accounts for users in Europe and the UK will experience delays until the maintenance is finished.
Additionally, card transactions will also be unsuccessful during the maintenance window. Please retry after the window, or use an alternative card if needed.
Furthermore, the creation of new GBP and EUR accounts may not be possible during the maintenance window.
We apologize for any inconvenience and appreciate your understanding in this matter.
Posted Sep 11, 2025 - 07:38 UTC
This scheduled maintenance affected: eToro Money (Cash Account, Debit Card, Fast Transfer (Online Banking)).