Portfolio balance and Instruments Profit/ Lost are displaying incorrectly

Incident Report for eToro

Resolved

Dear eToro Customers and Partners,

The incident has been resolved.

We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Oct 21, 2025 - 10:32 UTC

Investigating

We’re currently experiencing an issue where some some clients are experiencing a market data related display issue.
This is purely a display issue - your positions remain unaffected.

Our team has been identified and our engineering team is hard at work to resolve it as soon as possible.

We apologize for the inconvenience and thank you for your patience. Updates will be provided here as soon as available.

Sincerely,
The eToro team
Posted Oct 21, 2025 - 10:18 UTC
This incident affected: eToro Platform (Portfolio - History).