Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 21, 2025 - 02:00 UTC
Scheduled
To consistently ensure that you have the latest features and capabilities at your fingertips, eToro performs periodic upgrades to our system.
One of our 3rd party partners will undergo maintenance on May 21, 2025 from 02:00 GMT until approximately 04:00 GMT.
During this window, there may be a delay in incoming and outgoing payments to and from the eToro USD account, for GBP and EUR account (aka eToro Money) users, until after the maintenance has been completed.
Additionally, payments may also be unsuccessful during the maintenance window, and will need to be re-executed after its duration.
We apologize for any inconvenience and appreciate your understanding in this matter.
Sincerely, The eToro team.
Posted May 20, 2025 - 11:29 UTC
This scheduled maintenance affected: eToro Money (Cash Account, Fast Transfer (Online Banking)).