Issue with deposits for neteller
Incident Report for eToro
Resolved
Issue has been resolved on Netteler side. We're waiting for their support to provide more details, and keep monitoring to see that the service is up and running normally.
Posted Apr 23, 2020 - 18:10 BST