News Feed is partially unavailable. Issue is under investigation
Incident Report for eToro
Resolved
This incident has been resolved.
We apologize for the inconvenience.
Posted Mar 09, 2020 - 18:36 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2020 - 16:03 GMT
Investigating
We are currently investigating this issue.
Posted Mar 09, 2020 - 14:10 GMT
This incident affected: Apps (News Feed).