Login to eToro platform from China may be unavailable
Incident Report for eToro
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 02, 2019 - 09:16 BST
Monitoring
The incident has been resolved.
We will keep monitoring the issue.
We apologize for the inconvenience.
Posted 3 months ago. Aug 02, 2019 - 03:11 BST
Investigating
We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 3 months ago. Aug 02, 2019 - 02:58 BST
This incident affected: Apps (Login).