Some customers might not see statistics updating on eToro platform
Incident Report for eToro
Resolved
Dear Crypto Wallet Customers,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 25, 2022 - 13:19 UTC
Investigating
Hello,
Please note that we are currently experiencing technical issues with one of eToro’s services.
Our engineering team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 25, 2022 - 11:50 UTC
This incident affected: eToro Platform (Stats).