Credit cards deposit processing failures for some customers
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted May 01, 2021 - 06:39 UTC
Monitoring
We have implemented a solution to resolve the issue, and will monitor it for the next hours to make sure it is successfully resolved.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted May 01, 2021 - 05:34 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
There is a problem with a 3rd party provider that is making some of our deposits fail.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Apr 30, 2021 - 23:15 UTC
This incident affected: Payments (Deposit).