Login issues for Russian customers with 2FA enabled
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted 4 months ago. Jun 11, 2019 - 13:26 BST
Investigating
Customers from Russia might not receive the 2FA SMS verification.
Please bear with us while we work on resolving the issue and stay tuned for further updates.
We apologize for the inconvenience.
You are welcome to contact our support for assistance.
Posted 4 months ago. Jun 11, 2019 - 10:46 BST
This incident affected: Apps (Login).