Some landing pages are currently unavailable
Incident Report for eToro
Resolved
We are pleased to inform you that the problem that caused the landing pages to be temporarily unavailable has been resolved.

We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and completely resolved.

We appreciate your understanding and apologize for the inconvenience.


Sincerely,
The eToro Team
Posted Jun 23, 2020 - 21:28 BST
Monitoring
We have found the root cause for the issue and resolved it.

We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and completely resolved.
More updates will be provided here.

We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 23, 2020 - 21:20 BST
Investigating
Some of our landing pages are currently down. We apologize for the inconvenience and appreciate your patience as we work on resolving the issue.
Posted Jun 23, 2020 - 19:42 BST
This incident affected: Website.