Partial disruption when uploading files
Incident Report for eToro
Resolved
This incident has been resolved
Posted Apr 27, 2020 - 18:08 BST
Investigating
We're currently having a partial disruption when upload files. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Apr 27, 2020 - 13:36 BST