Login to etoro.com is partially unavailable
Incident Report for eToro
Resolved
We are keep monitoring the system for the next 24 hours to ensure it is addressed for all customers and resolved completely. Apologize for the interruption.
Posted May 27, 2020 - 20:04 BST
Update
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here. Apologize for the interruption.
Posted May 27, 2020 - 16:28 BST
Monitoring
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here. Apologize for the interruption.
Posted May 27, 2020 - 16:26 BST
Update
We're still working on solution. We will provide more updates here. Apologize for the interruption.
Posted May 27, 2020 - 16:09 BST
Update
We're still working on solution. We will provide more updates here. Apologize for the interruption.
Posted May 27, 2020 - 15:46 BST
Update
We are continuing to work on a fix for this issue.
Posted May 27, 2020 - 15:10 BST
Update
We are continuing to work on a fix for this issue.
Posted May 27, 2020 - 15:08 BST
Identified
We're currently experiencing a partial login issue. We've found the root cause for the issue and working to solve it.
Apologize for the interruption
Posted May 27, 2020 - 14:35 BST
This incident affected: Login & Registration (Login) and Platform (Watchlist, Portfolio - Real, Feeds, Discovery, Stats, Charts, Notifications).