some customers might not be able to close position on a single instrument
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted May 18, 2022 - 17:23 UTC
Investigating
We are experiencing a temporary issue with our Trading actions (Trade, Buy, Sell).
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted May 18, 2022 - 14:38 UTC
This incident affected: Trading (Manual trading - Real).