Some users may experience price update issues under Watchlist
Incident Report for eToro
Resolved
The issue has been resolved.
We apologize for the inconvenience
Posted Dec 08, 2019 - 08:12 UTC
Identified
The issue has been identified and a fix is being implemented
Posted Dec 02, 2019 - 16:31 UTC
Investigating
We have identified a technical malfunction preventing some users from partially seeing updated prices on mobile devices. This is currently being investigated by relevant key members.
Posted Dec 02, 2019 - 13:27 UTC
This incident affected: eToro Platform (Watchlist).