Clients from Indonesia may experience connectivity issue in the trading flow
Incident Report for eToro
Resolved
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here. Apologise for the interruption.
Posted May 06, 2020 - 15:12 BST
Identified
We've found the root cause for the issue and working on to solve it. We will provide more updates here. Apologise for the interruption.
Posted Apr 30, 2020 - 09:46 BST
Investigating
We are experiencing a temporary regional issue in Indonesia with our Trading flow (Instrument information, executing trading actions, etc).
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Apr 23, 2020 - 10:03 BST
This incident affected: Trading (Manual Trading, Copy Trading).