Deposit via PayPal may be unavailable
Incident Report for eToro
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 19, 2019 - 06:13 BST
Identified
We are experiencing issues with deposits via PayPal.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted about 1 month ago. Aug 18, 2019 - 23:50 BST
This incident affected: Payments (PayPal).