Withdrawals is partial unavailable
Incident Report for eToro
Resolved
This incident has been resolved.
Posted May 19, 2020 - 18:29 BST
Investigating
We are experiencing a partial issue with Withdrawals. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted May 19, 2020 - 17:24 BST
This incident affected: Payments (Withdrawals).